Translation target language

Hi! When I try to translate a post I receive the message

No translation target language set - this may fail. Please set a target language in your settings.

I cant find this target language on settings. I’ve tried with Chromium and Firefox.

I think in akkoma-fe it’s Preferences (little gear top-right) > General > “Automatic Translation Language”

Thanks for answering!

I don’t have this option nor anything in the word translate on it.

I’m on 3.10.4-1-gebfb617b

if you have the warning, you should have the setting


it’s here

1 Like

Thanks! But still I don’t have this option :frowning:

possible causes include:

  • you are running an outdated frontend
  • you have not actually set up any translation service
  • your translation service settings are incorrect
1 Like

My whole instance is about 3 weeks old So I guess everything is new enough.

My configuration is this:

So I guess it might be a problem with my API Key.

If I change to Argos it doesn’t give any other fields or options to choose. Is it an automatic service?

Argos Translate is command-line tool (or better put, a python library which can also be used as a command line tool). You have to install it and by default it expects to find the command in the PATH. There’s options for it, but it seems admin-fe doesn’t properly show those. Configuration Cheat Sheet - Akkoma Documentation

1 Like

just to be sure, what frontend version are you on? I have Backend version 3.10.4 and Frontend version e7a558a. You should see it in Preferences (little gear top-right) > Version.

1 Like

Backend version: 3.10.4-1-gebfb617b

Frontend version: e7a558a


I see. Thank you all. I will leave it be for a while, I don’t quite get how argos work, and I am afraid I don’t have enough resources to host a libre translate instance right now.

When I get the time I will learn more about it.

Anyway I really appreciate you all helping me.