[SOLVED] I broke federation sort of? ( tldr: I am an idiot)

umm, I think I have broken something and am unsure how to diagnose what; for a while I havce noticed that certain messages would not be fetched, even replies in the middle of a thread but other comments from the same user show up fine. Been going on a month or 2 from memory.

May be related: noticed just now someone I do not follow in my Home feed.

Any assistance/advice of where to poke around is much appreciated.

mhhh never heard of sth like that… did you look at the logfiles? is there sth strange?
Its normal, that a instance can’t fetch all remote posts. if tries to fetch a post, but can’t , there should be a error in the log. like connect timeout, or 404 not found… and so on

umm… it thinks posts are deleted when they are not?
I am assuming it is something stupid I have done. :person_facepalming:
User shows up fine, and other posts from them show up fine.

Apr 05 08:29:16 localhost pleroma[202714]: 08:29:16.150 [error] Could not fetch user https://mastodon.nz/@thomasbeagle110138130519336576, {nil, {:error, {"Object has been deleted", "https://mastodon.nz/@thomasbeagle110138130519336576", 404}}}
hmmm odd, I am searching from UI https://mastodon.nz/@thomasbeagle/110138130519336576 and it throws that. It shows one post as existing, but does not populate the search results with that post.

If I search for https://mastodon.nz/@thomasbeagle/110138122860356700 it works fine.


Rechecked searching @thomasbeagle@mastodon.nz/post/110138130519336576:


Apr 05 08:43:20 localhost pleroma[202714]: 08:43:20.151 [warning] Can't find LRDD template in "https://mastodon.nzpost110138130519336576/.well-known/host-meta": {:error, "non-existing domain"}

uhhh so this is different error this time…

I… -ahem- worked out that my AkkomaFE word filter settings were doing it.

Thank you all for your assistance, and I apologise for being such a cabbage and not remembering I even had word filters in place.

I only looked further as this issue persisted through two migrations to other hosts, moving from OTP to source on arm64, and now back again (love arm but mate is hosting it now) and the issue still persisted.

So glad I finally worked it out :joy: