Mailer doesn't work

Hello! I tried to configure Mailgun using AdminFE and config.exs, but it returns this on verification letter:

akkoma-server-1  | 20:17:14.831 [warning] Description: 'Authenticity is not established by certificate path validation'
akkoma-server-1  |      Reason: 'Option {verify, verify_peer} and cacertfile/cacerts is missing'

Could it be possible, that your server is missing a package containing ca certificates? What operating system are you using? If you try to access mailgun via curl on your server, does it work?

Iā€™m using self-built Docker image, anything changed since October? If yes, what package I should install? Iā€™m using alpine:3.16 as the base of image.

Or I should migrate to official Docker installation way?

You could try adding RUN apk add ca-certificates to your Dockerfile, to ensure that the certificates are available.

this error here could potentially be your HTTP adapter as well - did you install akkoma fresh, or migrate?

at any rate, check that your http adapter matches akkoma/config.exs at develop - akkoma - Akkoma Development

1 Like

Just fixed this exact error on smtp with Migadu, by changing starttls Mode to :never
It was :always

image

Well, I asked more knowledgeable friends that do this for a job and they said change that, and it worked.
Unsure if related to your mail setup, but sharing just in case.

1 Like