Is Akkoma accessible from private network?


I have my instance up and running with Docker and I can interact with it at localhost:4000.
Now I was wondering if it is possible to make the instance reachable from a private network ?
From my home PC say I can reach the IP server but the IP:4000 doesn’t work.

I played a bit around Misskey as well and there was this option in the default.yml file :

allowedPrivateNetworks: [

Is there something like that with Akkoma/Pleroma ?
I try looking around but no luck so far !

Thanks in advance

there is also a similar config for akkoma.
normally akkoma listens on if you want it to listen externally, without a reverse proxy you could set it to in your prod.secret.exs

it should look sth like this:

config :pleroma, Pleroma.Web.Endpoint,
   url: [host: "", scheme: "https", port: 443],
   http: [ip: {0, 0, 0, 0}, port: 4000],

but remember, this allows that you can reach the instance from every ip the server is exposed to

I saw this in the tutorial and did it so I have this in my prod.secret.exs

config :pleroma, Pleroma.Web.Endpoint,
   url: [host: "", scheme: "https", port: 443],
   http: [ip: {0, 0, 0, 0}, port: 4000],

but the instance is unreachable from my home network or my domain.

I tried installing pleroma in docker from this link

and the pleroma instance is up and running, reachable from everywhere without issues.
I do not understand because the config.exs from the pleroma instance has the same conf :

config :pleroma, Pleroma.Web.Endpoint,
  url: [host: System.get_env("DOMAIN", "localhost"), scheme: "https", port: 443],
  http: [ip: {0, 0, 0, 0}, port: 4000]

I try looking around the dif in the two files but without success.
I can add a link to them if you want.

Thanks for your time

mhh maybe its docker? what is the output of docker -ps?
does your port point to or 172.0.0:4000 in the output

I used angirstans docker_compose file years ago too… i think you have to change this line:

Sadly its years ago i used docker-compose, but i think you have bin the port to your hostip… aka sth like:

- ''
1 Like

Indeed with “docker ps” it seems that the conf has not been taken in account and it is pointing to

I’ll try to remove everything and start from scratch because my generated config has

ip: {0, 0, 0, 0}

so I don’t know what went wrong yet.

Edit :
I talk about the pleroma instance to show that when I tried with akkoma it failed but with pleroma it worked. Thanks for looking tho !
I am working with Akkoma right now :slight_smile:

your pleroma config should be correct, i edit my last post, afaik you have to tell docker to expose the port not to local host, but to your network ^^

1 Like

Indeed I forgot to change this in the docker-compose from the akkoma git repo !

I’ll build it from ground tomorrow morning, should be alright then !

I was starting to be lost with a thousand tabs open to look for the issue, thanks a lot !

Edit : I’m dumb, I just did a “docker compose down” then “docker compose up” and Boom !
Everything is going well, thanks !

1 Like