Hashtags from Akkoma are links on Mastodon?

Hi all,

Realized this recently, but whenever I use hashtags on my Akkoma instance, the hashtags render properly as just hashtags and when I add a URL, it will have the proper link preview.

However, the same post rendered from Mastodon when a Mastodon user views the same post, the first hashtag is a link back to a hashtag hosted on my instance and then the my actual link doesn’t appear as the link preview.

I’m not sure if it’s the way that Akkoma/Pleroma handles hashtags that’s different than Mastodon, but it’s kinda annoying that all posts from my Akkoma instance with a hashtag, the link preview is of the first hashtag because it’s being treated as a link instead of my actual link.


Example post with hashtag & link as rendered from my Akkoma instance.

Same post as rendered from Mastodon, the link preview shows a link to the Twitter hashtag that resides on my Akkoma instance instead of my actual URL.

Not sure if it’s just how it’s different between Akkoma/Pleroma and Mastodon or I misconfigured something.

Any assistance is greatly appreciated, thanks!

1 Like

na… i don’t think you misconfigured anything wrong. tbh you can’t even configure such stuff.

I think its mastodons fault here, if it renders stuff wrong.
Gonna test it out myself :3

I wonder what it does if the post doesn’t start with the hashtag

I just tried a couple of posts with hashtags both at the beginning and in the middle of posts and they seemed to render fine on mastodon.social.

Interesting, could it be a glitch-soc specific issue? Will try it on a vanilla Mastodon instance, thanks!

I had the same problem some hours ago. I tried to post an article, putting a description with some hashtags, then the link. On (vanilla) Mastodon, I could see a link to the first hashtag on the source Akkoma instance. I solved putting the link before the tags.

1 Like

I was just informed of this issue. When I thought it sounded weird I had a look at my old Akkoma posts, but from my other (testing) accounts on Mastodon, Calckey, Misskey, Hubzilla and Friendica. Indeed I noticed, in Mastodon, that it does this behaviour…sometimes…but not on others.

Those posts where it did it I also checked in the other services (as I then knew what to look for).
Those posts looked perfect (as in Akkoma) on Friendica, Calckey and Misskey.

Hubzilla had its own take on it, and kept the link intact (with no preview, it doesn’t do them) but all the hashtags were linked back as hashtags for my originating (Akkoma) instance.

Is there perhaps a disparity in ActivityPub on how hashtags should be handled?

And does Mastodon basically create a preview of the first thing it sees, regardless of the following content?

It’s happening with a lot of my posts. I’ve also a Mastodon account and this is what comes out almost every time I post some text with hashtags

People contact me saying “hey, your link isn’t working”.

I don’t know if it’s a Mastodon or Akkoma’s problem, but I can see it when I post from my Akkoma instance.

Any hint/suggestion?

@FloatingGhost - any hint about this issue? It’s quite annoying :frowning: - thank you!

i’m not a mastodon developer, i can’t explain what it does or why it does it

this doesn’t happen on non-mastodon software, so take it up with them

1 Like

Ok, I will try to ask them. Since it’s only happening when posting from Akkoma and being Mastodon the most deployed Fediverse software (surely not my favourite if I’m here :wink:), I just thought it could be easier / more effective to debug it our side.

I’ll eventually post an update here when Mastodon developers will reply.

I have noticed Friendica doing weird stuff when replying; both akkom and mastodon interpret the mention as a link to the user’s profile. So likely just an interpretation of whatever the AP implementation is doing with the first link it sees.

I guess make a habit of having the hashtags further down the post or a bunch at the end, as a work-around.

Yes, I noticed this on Friendica yesterday too. When I ran my tests Friendica did get it right (when Mastodon got it wrong). Think I shall have a look at what is different between my test posts and the post I did yesterday, and see if I can force it to happen again in Friendica, in which case I’ll tell the Friendica guys.

I just noticed someones intro post had a bunch of hashtags, and when I checked their profile it had the first hashtag as a link. This was their own post on their own instance, so… it is just a mastodon thing/bug/feature.