Fresh Akkoma Instance - Cannot Follow/View All Posts & Other Instances Can't Find Me - Federation Broken?

Hi all,

Facing a problem that’s driving me up the wall. Recently wanted to deploy my own Fediverse instance for my personal use. I initially chose Pleroma due to its low system requirements so I don’t need to spend a fortune for a large VPS. Was able to install it without issues and can see the frontend.

However, when I’m working to move my Mastodon profile to my Pleroma instance, I realized that I can’t follow myself and I can’t see any of my posts. When I check out another profile on the same instance, I can see the profile and a few posts but not all the posts/media. When I tried searching for myself on the other instance, it tries to contact my instance but it then returned “Error 503, Remote data could not be fetched”.

I thought the issue was with Mastodon as I tried doing the same action on multiple Mastodon instances, including the large regional instance I’m a part of ( However, I tried navigating to a couple Akkoma & Pleroma instance and the same issue, I can’t follow anyone and either I can’t see any posts/follows or if there are posts, I can only see a few, usually pinned posts.

I even tried registering my instance on but the site threw the following error:

Sign up failed. It looks like this instance is not a Mastodon or Pleroma instance. Other fediverse instances can show up on but are not (yet) compatible with this admin space.

I thought Pleroma was the issue so I found out about Akkoma and tried a fresh install of Akkoma but ended up with the same issue.

My instance is hosted on a VPS behind Cloudflare, I thought that might also be an issue so I disabled Cloudflare’s proxy but that didn’t fix the issue either.

My Akkoma/Pleroma configuration are the default, federation is set to enabled, the NGINX configuration is default, only modifying for my domain name and for webroots for the ACME challenge. The domain name is fresh, just registered for it yesterday.

Any help would be greatly appreciated as I’m not sure what’s causing this. I’m an Akkoma, Pleroma/Mastodon admin newbie so maybe I’m missing something that I’m unaware of.


what domain did you set up on? can take a poke to see if anything is obviously weird

@FloatingGhost Thanks for the quick reply, much appreciated.

My instance is:

you’ve got a redirect loop

you may want to check your cloudflare setting to see if it’s trying to use TLS between server and client

you’ll probably want to make it full or full (strict)

@FloatingGhost ah thanks, didn’t realize that SSL setting would cause issue. Made the change, was able to get the other instance at to be able to see my instance and profile.

However, when I tried following myself on the instance, the request is sent but I don’t see the request on the other end. When I tried to view posts from users on that instance and of other instances, I can see the profile but there are no posts either. The follows/follower count is also 0 as well even though I know these profiles have high follows/follower count. Is there something else that I’m missing?


that’s normal - it’s a side-effect of how federation works

it’ll calculate “follower count” based on how many followers your instance knows about, and given that your instance is brand new, that’s none

after following people, posts will start to be sent to your instance

also, regarding follow requests - it’s probably mastodon being weird about new instances again, it does that, give it an hour or so and try again

it’s probably queued a request to check your instance

@FloatingGhost ah I see, alright, will wait & see. Just wanted to make sure that I can get the basic functionality working before moving my Mastodon profile over to my Akkoma instance.

Will check back in an hour or so to see if it went through.

Again thanks, much appreciated!

@FloatingGhost it looks like even though the federation has been working better than before, I’m able to follow people but when people try to follow me, I see the notification but on their end, they see that the request was sent but they’re not actually following me. They also don’t see any of my profile changes or posts either.

Another issue is that I’m trying to follow others but the follow now works but then I can’t see their posts. Here’s an example:

Even though it lists 0 in my instance, this user has 181 posts according to their profile.

Looks like even though we fixed the federation issue where the other server can’t see my server, there seems to be an issue when it comes to cross-communication still.

Any assistance is greatly appreciated, thanks!

it is normal to not see all of their posts

ref: How Federation Works | Lainblog

1 Like

@FloatingGhost, ah makes sense. Looks like everything is in working order, thanks again, much appreciated!