"exec: /opt/akkoma/erts-13.1.2/bin/erlexec: not found"

hi getting this error trying to install akkoma.

erlexec is present in the /erts-(version)/bin/ directory.

also encountered an error with the zip command copied from guide (zip not found? I just extracted the downloaded zip - not the renamed one & chowned the release directory for akkoma:akkoma) not sure if that could somehow affect installation.

also tried installing from source however several packages were out of date & compilation kept stopping.

running debian 11 on vps, basically new install.

thanks, any help appreciated.

which version of erlang do you use?
I switched to ubuntu cause the debian erlang was really old

“erlang (1:23.2.6+dfsg-1” is installed.

could you try
elixier --version

elixir was not installed, after installation, command still fails to find erlexec.

elixir version (1.10.3.dfsg-1.1)

the command I am trying to use is :
su akkoma -s $SHELL -lc “./bin/pleroma_ctl instance gen --output /etc/akkoma/config.exs --output-psql /tmp/setup_db.psql”

fails with error:

/opt/akkoma/releases/3.5.0-0-g63f2d1cbe/…/…/erts-13.1.2/bin/erl: 12: exec: /opt/akkoma/erts-13.1.2/bin/erlexec: not found

did set the correct flavor at start of the guide?

# Set the flavour environment variable to the string you got in Detecting flavour section.
# For example if the flavour is `amd64-musl` the command will be
export FLAVOUR="amd64-musl"

Also… you said the unzip command failed? did u use the full download command?

# Clone the release build into a temporary directory and unpack it
su akkoma -s $SHELL -lc "
curl 'https://akkoma-updates.s3-website.fr-par.scw.cloud/stable/akkoma-$FLAVOUR.zip' -o /tmp/akkoma.zip
unzip /tmp/akkoma.zip -d /tmp/

it could be you downlaoded the wrong flavor?
I’ve never seen your error, thats why i’m asking so much questions XD

this error typically happens when you download the glib version on a musl system of vice versa

1 Like

I definitely exported the correct flavour. the zip file had “amd64-musl” in the filename. ls tmp shows “akkoma-amd64-musl.zip”.

I did use the full command, there was a peculiar error that amounted to like invalid package or file not found, however the zip could still be extracted normally.

also I just checked in akkoma ~ & the ownership is correct also I think permissions too, the akkoma user has x rights.

musl, is for alpine linux, you need amd64 for debian

export FLAVOUR="amd64"

after that redownload it again, it should work with that :innocent:

oh duh, sorry to waste your times.

thanks for helping me work that out, I figured it was something simple.

I still get this error on download - the transfer cuts out?

 su akkoma -s $SHELL -lc "
> curl 'https://akkoma-updates.s3-website.fr-par.scw.cloud/stable/akkoma-$FLAVOUR.zip' -o /tmp/akkoma.zip
> unzip /tmp/akkoma.zip -d /tmp/
> "
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
 83 19.3M   83 16.1M    0     0   237k      0  0:01:23  0:01:09  0:00:14  203k
curl: (56) OpenSSL SSL_read: Connection reset by peer, errno 104
Archive:  /tmp/akkoma.zip
  End-of-central-directory signature not found.  Either this file is not
  a zipfile, or it constitutes one disk of a multi-part archive.  In the
  latter case the central directory and zipfile comment will be found on
  the last disk(s) of this archive.
unzip:  cannot find zipfile directory in one of /tmp/akkoma.zip or
        /tmp/akkoma.zip.zip, and cannot find /tmp/akkoma.zip.ZIP, period.

ahh i found the error… it s actually an error in the doc
Replace ’ with "

curl 'https://akkoma-updates.s3-website.fr-par.scw.cloud/stable/akkoma-$FLAVOUR.zip' -o /tmp/akkoma.zip


curl "https://akkoma-updates.s3-website.fr-par.scw.cloud/stable/akkoma-$FLAVOUR.zip" -o /tmp/akkoma.zip

I now get

"!!! Config path is not declared! Please ensure it exists and that AKKOMA_CONFIG_PATH and/or PLEROMA_CONFIG_PATH is unset or points to an existing file

when I am running

“su akkoma -s $SHELL -lc “./bin/pleroma_ctl instance gen --output /etc/akkoma/config.exs --output-psql /tmp/setup_db.psql””

Oh… it works for me… i tried it before via sudo, there it didn’t set the variable correctly in the sudo env

root@rick-akkoma-1:~# su pleroma -s $SHELL -lc " echo $FLAVOUR
curl 'https://akkoma-updates.s3-website.fr-par.scw.cloud/stable/akkoma-$FLAVOUR.zip' -o /tmp/akkoma.zip
file /tmp/akkoma.zip
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 19.3M  100 19.3M    0     0  22.6M      0 --:--:-- --:--:-- --:--:-- 22.6M
/tmp/akkoma.zip: Zip archive data, at least v1.0 to extract, compression method=store

this is entirely fine

ok now it tells me when I attempt to do the following line of the guide that a database named with my proposed url does not exist.

"su postgres -s $SHELL^[[200~su postgres -s $SHELL -lc "psql -f /tmp/setup_db.psql"
psql:/tmp/setup_db.psql:1: ERROR:  role "akkoma" already exists
psql:/tmp/setup_db.psql:2: ERROR:  syntax error at or near "."
LINE 1: CREATE DATABASE my-fedi-url OWNER akkoma;
psql:/tmp/setup_db.psql:3: error: \connect: FATAL:  database "my-fedi-url" does not exist"

how do I proceed?

that’s not a valid database name

see PostgreSQL: Documentation: 7.0: Names

hi the actual database name is separated with dots, is that valid? sorry I replaced it w a placeholder.