Error when trying authenticate via LDAP

Hello, I have been trying to set up LDAP on my newly created Akkoma instance by using the :ldap section of the configuration cheat sheet. Unfortunately I am getting an error that I don’t understand.

“request_id=F3uZLIPO8R8CKjEAABlC [error] Internal server error: %UndefinedFunctionError{module: :eldap, function: :open, arity: 2, reason: nil, message: nil}”

The Akkoma instance is installed on a VM via the docker install documentation and the LDAP server is on a seperate host. I have tried setting the config via the prod.secret,exs and via the admin-fe both result with the same error. I have also tried port 389 and 636 with SSL and TSL on and off for their respective ports. Any help or guidance on how to approach this would be appreciated

if you installed from source there is a probability that you do not have eldap

no idea what distro you’re on but you may want this package

That makes sense. I am using Ubuntu server. If i understand correctly since this is installed via the docker instructions the package will have to be installed in the Akkoma docker container rather than the host system. Does that sound correct?

yes, that would be correct

I ended up switching to the OTP release with eldap included. LDAP is attempting to connect now when logging in but, I’m getting “could not open LDAP connection”. ldapsearch from the akkoma host is able to connect when adding a bind user and password but I get an insufficient access error when I don’t add the bind user. I suspect that this is an issue with my ldap configuration and anonymous search. I don’t see anything in the configuration cheat sheet about adding a bind user for akkoma so I think troubleshooting this going forward might be on my authentik ldap configuration rather than Akkoma. Thanks for the help so far

Not sure if this helps (I don’t use or very much know ldap), but yunohost also uses otp and ldap, this is the config they use for it

(They add the content of this file at the end of the akkoma config file, see )

Thanks. I’ll take a look at that. So far I’ve been trying to configure this via the admin-fe. I’ll clear the admin-fe config and try via the config file. Also, out of curiosity in the case where the admin-fe and config file conflict on a setting do the changes in the configuration file override the admin-fe or is it the other way around? Thanks for the help and dealing with my inexperience.

db overwrites config files