ERROR 42501 (insufficient_privilege) permission denied for table users

Hi, I’m trying to upgrade my Akkoma instance. After the upgrade, creating posts or reactions does not work.

I tried GRANT PERMITIONS for tables, functions and sequences on all schemas for the user, but that doesn’t work. I also tried logging in as postgres or updating to develop branch but that also does not work.

I’m using official Docker installation and develop branch


akkoma-akkoma-1  | 22:42:15.089 request_id=F1N5vChn0kntMp0AABvh [error] Internal server error: %Postgrex.Error{connection_id: 1383752, message: nil, postgres: %{code: :insufficient_privilege, file: "aclchk.c", line: "3650", message: "permission denied for table users", pg_code: "42501", routine: "aclcheck_error", severity: "ERROR", unknown: "ERROR", where: "SQL statement \"SELECT COALESCE(users.follower_address, '')         from public.users where users.ap_id = actor\"\nPL/pgSQL function activity_visibility(character varying,character varying[],jsonb) line 6 at SQL statement\nPL/pgSQL function update_status_visibility_counter_cache() line 15 at assignment"}, query: nil}
akkoma-akkoma-1  | 
akkoma-akkoma-1  | 22:42:15.100 [error] #PID<0.2366.0> running Pleroma.Web.Endpoint (connection #PID<0.2365.0>, stream id 1) terminated
akkoma-akkoma-1  | Server: (http)
akkoma-akkoma-1  | Request: POST /api/v1/statuses/AUNlX22UCwDCbIMP1E/favourite
akkoma-akkoma-1  | ** (exit) an exception was raised:
akkoma-akkoma-1  |     ** (Postgrex.Error) ERROR 42501 (insufficient_privilege) permission denied for table users
akkoma-akkoma-1  |         (ecto_sql 3.9.2) lib/ecto/adapters/sql.ex:913: Ecto.Adapters.SQL.raise_sql_call_error/1
akkoma-akkoma-1  |         (ecto 3.9.5) lib/ecto/repo/schema.ex:756: Ecto.Repo.Schema.apply/4
akkoma-akkoma-1  |         (ecto 3.9.5) lib/ecto/repo/schema.ex:369: anonymous fn/15 in Ecto.Repo.Schema.do_insert/4
akkoma-akkoma-1  |         (pleroma 3.7.1-209-g2a8c1f41-develop) lib/pleroma/web/activity_pub/activity_pub.ex:130: Pleroma.Web.ActivityPub.ActivityPub.persist/2
akkoma-akkoma-1  |         (pleroma 3.7.1-209-g2a8c1f41-develop) lib/pleroma/web/activity_pub/pipeline.ex:49: Pleroma.Web.ActivityPub.Pipeline.do_common_pipeline/2
akkoma-akkoma-1  |         (ecto_sql 3.9.2) lib/ecto/adapters/sql.ex:1203: anonymous fn/3 in Ecto.Adapters.SQL.checkout_or_transaction/4
akkoma-akkoma-1  |         (db_connection 2.4.3) lib/db_connection.ex:1611: DBConnection.run_transaction/4
akkoma-akkoma-1  |         (pleroma 3.7.1-209-g2a8c1f41-develop) lib/pleroma/web/activity_pub/pipeline.ex:28: Pleroma.Web.ActivityPub.Pipeline.common_pipeline/2
akkoma-akkoma-1  |