Cannot upload/attach MP4 video to a post

Hello all,
I just created an akkoma instance and things seem to work fine. The problem though is that I cannot attach mp4 video files to a post. I have increased the upload size limit but that is not the problem.
On the GUI, I get Error: Upload failed. Try again later.
On the server I do not see an error running journalctl -u akkoma.
Any thoughts on what could the issue be here?


only mp4? images etc can upload fine?

I just tried an mp4 and it uploaded fine on my instance, which I know isn’t helpful.

Yeah, it is mp4 so far. Images get uploaded just fine. I have no tested other video formats though.

If you have upload filters enabled, maybe you can try disabling them and see if one of those gives the problem. (Admin-fe > Settings > Upload > Filters)

Thanks for the suggestion. I tried that and still no luck.

OK, I tried a very small video (~ 10 MB) and it uploaded just fine. However, I have increase the upload file size limit and on the first page I see this:

Scope options
Text limit = 10000
Upload limit = 150 MiB

Doesn’t this mean that I should be able to upload videos of up to ~150MB in size?

yes, but your reverse proxy must also be configured to allow that

Thanks, any more details on how to do this?
Should I be updating /etc/nginx/sites-available/akkoma.conf?

yes, nginx docs will tell you what to do

it’s like max_body_size or something I forget

Great. That solved the problem. Thanks!