Akkoma stable 2023.04 - switchable front timeline visibility hehe

Apologies for the weird timing on this month’s release, i was back with my parents for easter and i’m off at a concert tomorrow, all over the place, not exactly conducive to a stable release cycle, eh?


New stuff

The long-awaited frontend switcher (alpha version)

This is about an entire year in the making on the akkoma side, and about 3 years in the making on the codebase in general.

Users can now select the frontend they prefer. This is limited, but it does work! I decided to release it now to figure out if people will use it, and what live limitations it has that i have not foreseen.

To enable switching frontends, ensure the setting :pleroma, :frontends, :pickable is populated - it should look like "pleroma-fe/stable", "someotherfe/dist"

Then the above UI will be available at /akkoma/frontend

Mastodon frontends cannot be used here.

Far more ability to set timelines to be public/private

Want to make the bubble timeline public? Now you can!

The entire timeline visibility system has been upraded.


This is also handled far more comfortably in akkoma-fe! So you should see less of those awkward 401 messages for logged out users.

Also a bunch of bug fixes

Check out the changelog for more information


Is the same as ever!

See Updating your instance - Akkoma Documentation


This months (and a bit), thankies go out to:

  • sanek for fixing a bug with drafts
  • xarvos for fixing an issue with poll expiration times
  • norm for standardising version information
  • foxing for adding feature flags to help with client feature negotiation
  • flisk for fixing a crash condition. sorry for accidentally doing the same thing as you in FE!
  • ilja for removing a default that didn’t make too much sense
  • hehecat for hehecat things

Looks like the docker instance is failing to build when following the update directions here:


 ---> Running in ee54bebec58e
addgroup: gid '0' in use
The command '/bin/sh -c addgroup -g $GID $UNAME' returned a non-zero code: 1
ERROR: Service 'akkoma' failed to build : Build failed
Building db
Sending build context to Docker daemon  2.048kB
Step 1/7 : FROM postgres:14-alpine
 ---> 09b26fe01cdd
Step 2/7 : ARG UID=1000
 ---> Using cache
 ---> 541ebc32df1e
Step 3/7 : ARG GID=1000
 ---> Using cache
 ---> 0e6951017184
Step 4/7 : ARG UNAME=akkoma
 ---> Using cache
 ---> 775790ef08a3
Step 5/7 : RUN addgroup -g $GID $UNAME
 ---> Running in afb4afc00839
addgroup: gid '0' in use
The command '/bin/sh -c addgroup -g $GID $UNAME' returned a non-zero code: 1
ERROR: Service 'db' failed to build : Build failed

updated and happy!

I’m most happy with being able to have the bubble tl as default for non-logged-in users, instead of the federated tl. No more putting time and work in cleaning the federated tl, it’s just comfy by default now :smiling_face_with_three_hearts:

Thx person and people who contributed to this! :hugs:

1 Like

Ok. I was able to get this worked out. I think there were some permissions issues within my docker working folder (it’s always permissions!) Anyway, after sorting that out, the update went very smoothly. Thanks for your hard work on akkoma @FloatingGhost and all other contributers!

Where do I find the frontend switcher? Is it on Akkoma-fe? After upgrading, I searched the page for a long time but couldn’t find it.


Then the above UI will be available at /akkoma/frontend

1 Like

Thanks once again for all of your great work. I had to work out how to install newer versions of elixir/erlang using asdf but all looks good now. One small question: where is the option to “have the bubble tl as default for non-logged-in users”? I can’t seem to find it. I tried disabling the federated timeline for non-logged in users in the “Instance” menu, but it still appears as the default, but with a 401 error instead of posts.

Thanks a lot to all the people who contributed to this <3
Does Elixir 1.14 is also required for OTP installs ?

No, OTP comes with everything needed packaged, so you don’t have to install elixir when using OTP installs.

1 Like

Redirect root no login option

1 Like

and what did you do to make it work?
i have the same problem.

If it helps at all, I was able to go from Ubuntu 22.04 to Ubuntu 23.04 to get the update to work (as Ubuntu 23.04 comes with elixir 1.14). asdf did not seem to work for me for this