Trying to follow relays but fails to do so, in both admin-fe and cli


i’m trying to follow a relay, but it just doesn’t work.

  1. in admin-fe, under ‘relays’ sidebar menu, i entered desired relay’s URL (ending in /actor) to the textfield, clicked ‘follow’
    → it failed with this message: Request failed with status code 500 - the_url_i_entered
  2. in cli, i issued this command: MIX_ENV=prod mix pleroma.relay follow the_url_i_entered, but it also failed with this output: Error while following the_url_i_entered: :not_found

what does :not_found mean here? i assume this doesn’t mean the host is not reachable, because i can from my web browser. i’m very confused right now.
any help please?

also seems to be a side effect of this failed attempt to follow a relay: my instance’s ‘known network’ is now being populated with all sorts of “unrelated to the relay topic” instances.

Some relays suck.
A mate changed his to another sort and my instance could follow that one fine… it errored out every time on the old one.


yeah, i was able to confirm that another relay i tried is okay without any problem. this particular relay i tried earlier seems to be problematic…

thank you, wise one!

1 Like