Activate Akkoma in-database configuration: 'cp: cannot stat 'config/dev.secret.exs': No such file or directory' error message

Background: I’m in an OTP installation and am trying to install the Mangane frontend. I followed the steps on their page. But now I get the Request failed with status code 500 toast message whenever I go to the Frontend page (See pic). By Frontend page, I mean pleroma/admin/#/settings/frontend


The developer for Mangane asked, “Did you activated in database configuration?” and shared the link below. Now, the guide (link below) says :

  1. It is recommended to backup your config file now.
    cp config/dev.secret.exs config/dev.secret.exs.orig
    Running the above at root gives me the following error message.
    cp: cannot stat 'config/dev.secret.exs': No such file or directory

  2. Edit your Akkoma config to enable database configuration.
    config :pleroma, configurable_from_database: true
    However, the following is already in my config.exs file.

Link to documentation: How to activate Akkoma in-database configuration - Akkoma Documentation

Moreover, the Available Frontends sections in Frontend settings is now totally blank for my instance. I however do see the the Mangane Frontend activate. Where am I going wrong here?

you’re running from-source commands when you do not run from-source

please use the OTP commands

Oh. Could you please share a ‘sample’ or syntax of an OTP command?

E.g OTP of this cp config/dev.secret.exs config/dev.secret.exs.orig command would be?

it wouldn’t be

you don’t need to do that

you’ve already copied it - your config is at


Correct. That’s what confuses me. The documentation of the FE I’m trying to install is just not done well IMHO.

The FE seems to work but now whenever I go to the Frontend page on Admin FE I get the Request failed with status code 500 posted above. Not to mention all the FEs installed by default are gone - the area is blank now.

By ‘Blank’ I mean this.

sounds like akkoma doesn’t know where your config is

iirc you posted in another thread with that exact warning

Oh. How do I correct that i.e let Akkoma know where my config is?

it told you in the error message

Side question - Can Mangane co-exist with Pleroma-FE, using Pleroma-FE as the default?

I used this to install Soapbox (which Mangane is a fork of) on a subdomain to be able to use either or.

It should work similarly for Mangane

@gamerfort I actually moved from Soapbox to Mangane - what with the list of additional features that it has. List below (not my wording). But I guess it’s been quite a struggle since the documentation has been ‘confusing’ and difficult to comprehend esp the location of where to place folders etc.

  • [CH] Add local and fediverse timeline in thumb menu, move serach icon in top navigation (#13)
  • [CH] Add search Icon in tabs_bar, remove search from thumbs bar
  • [CH] Add local et fediverse timeline access in thumb menu
  • [ADD] Add multiple screen to the onboarding to explain what’s the fediverse is about
  • [Add] Add akkoma support, soapbox didnt dectected Akkoma correctly
  • [CH] Local timeline logo is now instance logo. Instance logo must be svg only. Remove name from Manifest.json (#64)
  • [FIX] Edit chat check (#65)
  • [CH] Better UX for polls (#66) *[FIX] Translate config panel, bookmark,muted words, import data pages in French (#67)
  • [FIX] use actualStatus hidden state boosted status with CW are now working correctly (#76)
  • [CH] Move custom enlistment directly in the pre-existing onboarding (#73)
  • [CH] Rework the profile directory (#77)
  • [ADD][FIX] Add a detailed home description, Show admins and moderators on front page. Fix footer links on mangane settings page. (#83)
  • [Fix] translations (#84)
  • [CH] Back arrow should stick to the top of the screen (#86)
  • [Fix] wrong request on admin dashboard (#85)
  • [FIX] Fix translation tone
  • [REM] Remove useless onboarding setting
  • [ADD] Add a manifest.json for webapp

For what it’s work, I tried this out with a new subdomain for mangane and it worked just fine for my instance.

1 Like

I installed it as a new subdomain to give it a try. It is a little nicer than soapbox, for sure. I am going to wait until it has more feature parity with the Pleroma-FE though since I heavily use the newer features added by Akkoma (auto-translate support, custom reaction gifs, as well as showing only replies to me, for example.)

Hopefully when the new follow hashtag feature gets pushed to the OTP release, I’ll be using that a lot as well.